Translating Mindjet MindManager Files

From Wordfast Wiki
Jump to: navigation, search

From the Mindjet MindManager application, choose File > Save As… and save your mindmap file in the MindManager Map (XML) format.

If you open .xmmap file in a text editor, you will see that the translatable parts are identified in the attribute: PlainText.

To translate the .xmmap in Wordfast Pro, you first need to create a very simple extraction rules *.properties file (click here to download it)

paragraphPrefix.0=PlainText="
paragraphSuffix.0="

Next, you’ll need to create a text-based filter that so Wordfast Pro will recognize the .xmmap extension and use the *.properties file rules to extract the proper content.

Wordfast Pro 3

To open the .xmmap file in Wordfast Pro 3:

  1. Go to Edit menu > Preferences > Formats > New > Text-based Filter.
  2. Click the [...] button to locate the (*.properties) file. Make sure the "Extension" textbox shows *.xmmap and save the settings (OK).
  3. Open the .xmmap file in WFP3 (File menu > Open file).

After translating and saving the file back to its native .xmmap format, open the translated .xmmap file in Mindjet MindManager.


Wordfast Pro 5

  1. Go to the Wordfast Pro menu > Preferences > New Project Preferences > Filters.[1]
  2. Click on the Add button.
  3. Choose the file format Text-based filter (*xml).
  4. Give your filter a name (e.g. Mindjet).
  5. Use UTF-8 for the source and target encoding.
  6. Use the Browse... button next to "Extraction rules" to locate the extraction rules (*.properties) file.
  7. Make sure the "Extension" field shows xmmap and save the settings by pressing OK.
  8. Now, when creating a new project, you can add the Mindmap file and it will use this newly created filter. If you have more than one customized .xmmap filter, you will be able to choose which filter to use when adding the .xmmap file.

After translating and saving the file back to its native .xmmap format, open the translated .xmmap file in Mindjet MindManager.


References

  1. If you want to add a .xmmap file to an existing project, open the project first, then open Preferences > Current Project Preferences > Filters and go to step 3.



--Yasmin Moslem 05 June 2012

Version: Wordfast Pro 5.7
Operating System: macOS

Updated by Star 15 January 2019